Apache Tomcat 7.0.x < 7.0.4 File Permission Bypass Vulnerability

Low Log Correlation Engine Plugin ID 800608


The remote web server is affected by a security bypass vulnerability.


Versions of Tomcat 7.0.x earlier than 7.0.4 are potentially affected by a security bypass vulnerability. When running under a SecurityManager, it is possible to grant a web application read/write permissions to any area on the file system.


Upgrade to Apache Tomcat 7.0.4 or later.

See Also


Plugin Details

Severity: Low

ID: 800608

File Name: 800608.prm

Family: Web Servers

Published: 2011/02/13

Nessus ID: 51958

Risk Information

Risk Factor: Low


Base Score: 1.2

Temporal Score: 1

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/10/21

Vulnerability Publication Date: 2011/02/05

Reference Information

CVE: CVE-2010-3718

BID: 46177