Apache Tomcat 7.0.x < 7.0.22 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800605
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

Versions of Tomcat 7.0.x earlier than 7.0.22 are potentially affected by multiple vulnerabilities:

- An information disclosure vulnerability exists. Request information is cached in two objects and these objects are not recycled at the same time. Further requests can obtain sensitive information if certain error conditions occur. (CVE-2011-3375)

- The web server is not properly restricting access to the servlets that provide the functionality of the Manager application. This can allow untrusted web applications to access privileged internal functionality such as gathering information on running web applications and deploying additional web applications. (CVE-2011-3376)
IAVB Reference : 2012-B-0035
STIG Finding Severity : Category I

Solution

Upgrade to Apache Tomcat 7.0.22 or later.

See Also

http://www.nessus.org/u?4bf28407

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.22

Plugin Details

Severity: Medium

ID: 800605

Family: Web Servers

Published: 2/22/2012

Updated: 2/22/2012

Nessus ID: 57082

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 11/25/2011

Vulnerability Publication Date: 12/28/2011

Reference Information

CVE: CVE-2011-3375, CVE-2011-3376

BID: 51442, 50603