Apache Tomcat 6.0.x < 6.0.33 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800602


The remote web server is vulnerable to multiple attack vectors.


Versions of Tomcat 6.x earlier than 6.0.33 are potentially affected by multiple vulnerabilities :

- An error handling issue exists related to the MemoryUserDatabase that allows user passwords to be disclosed through log files. (CVE-2011-2204)

- An input validation error exists that allows a local attacker to either bypass security or carry out denial of service attacks when the APR or NIO connectors are enabled. (CVE-2011-2526)

- A component that Apache Tomcat relies on called 'jsvc' contains an error in that it does not drop capabilities after starting and can allow access to sensitive files owned by the super user. Note this vulnerability only affects Linux operating systems and only when the following are true: jsvc is compiled with libpcap and the '-user' parameter is used. (CVE-2011-2729)


Upgrade to Apache Tomcat 6.0.33 or later.

See Also



Plugin Details

Severity: Medium

ID: 800602

Family: Web Servers

Published: 8/30/2011

Updated: 8/30/2011

Nessus ID: 56008

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 8/18/2011

Vulnerability Publication Date: 6/27/2011

Reference Information

CVE: CVE-2011-2204, CVE-2011-2526, CVE-2011-2729

BID: 48456, 48667, 49143