Apache Tomcat 6.0.x < 6.0.32 Denial of Service Vulnerability

Medium Log Correlation Engine Plugin ID 800599


The remote web server is vulnerable to a denial of service attack.


Versions of Tomcat 6.x earlier than 6.0.32 are potentially affected by a denial of service vulnerability because the NIO connector expands its buffer endlessly during request line processing.


Upgrade to Apache Tomcat 6.0.32 or later.

See Also


Plugin Details

Severity: Medium

ID: 800599

Family: Web Servers

Published: 2011/02/11

Nessus ID: 51987

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/02/03

Vulnerability Publication Date: 2011/11/05

Reference Information

CVE: CVE-2011-0534

BID: 46164