Apache-SSL < 1.47 mod_ssl i2d_SSL_SESSION Function Overflow

High Log Correlation Engine Plugin ID 800591

Synopsis

The remote web server is vulnerable to a buffer overflow.

Description

The remote host is using a version of Apache-SSL which is older than 1.47. This version is vulnerable to a buffer overflow which may allow an attacker to execute arbitrary commands on this host.

Solution

Upgrade to version 1.47 or higher.

See Also

http://www.apache-ssl.org/advisory-20020301.txt

http://archives.neohapsis.com/archives/bugtraq/2002-02/0313.html

http://archives.neohapsis.com/archives/bugtraq/2002-03/0000.html

http://archives.neohapsis.com/archives/bugtraq/2002-03/0012.html

Plugin Details

Severity: High

ID: 800591

File Name: 800591.prm

Family: Web Servers

Nessus ID: 10918

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2002-0082

BID: 4189