Apache mod_auth_pgsql < 0.9.6 SQL Injection

High Log Correlation Engine Plugin ID 800588

Synopsis

N/A

Description

The remote host is running a version of mod_auth_pgsql which is older than 0.9.6. It is vulnerable to a SQL injection attack which may let anyone bypass authentication or even modify your database.

Solution

Upgrade to mod_auth_pgsql 0.9.6 or higher.

See Also

archives.neohapsis.com/archives/vulnwatch/2001-q3/0040.html

Plugin Details

Severity: High

ID: 800588

File Name: 800588.prm

Family: Web Servers

Nessus ID: 10752

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2001-1379

BID: 3251, 3253