Apache < 2.0.51 mod_ssl Rewrite Rules DoS

Medium Log Correlation Engine Plugin ID 800587

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote host appears to be running a version of Apache 2.x that is older than 2.0.51. It is reported that these versions of Apache are prone to a denial of service issue related to mod_ssl. An attacker may deny service to legitimate users if the remote server uses a 'RewriteRule' to enable reverse proxying to a SSL origin server.

Solution

Upgrade to version 2.0.51 or higher.

Plugin Details

Severity: Medium

ID: 800587

File Name: 800587.prm

Family: Web Servers

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0786, CVE-2004-0809, CVE-2004-0751

BID: 11154