Apache < 2.0.51 ${ENVVAR} Local Overflow

Medium Log Correlation Engine Plugin ID 800562

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a vulnerable version of Apache. It is reported that versions prior 2.0.51 are prone to a local buffer overflow when processing ${ENVVAR} constructs in .htaccess and httpd.conf files. An attacker with interactive access to the computer may use this flaw to execute arbitrary code in the context of the web server.

Solution

Upgrade to Apache 2.0.51 or higher.

Plugin Details

Severity: Medium

ID: 800562

File Name: 800562.prm

Family: Web Servers

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 3.7

Temporal Score: 2.7

Vector: CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0811, CVE-2004-0809, CVE-2004-0786, CVE-2004-0747

BID: 11239, 11182