Apache mod_ssl Session Cache Code Overflow

High Log Correlation Engine Plugin ID 800557

Synopsis

The remote web server contains a vulnerability that would allow an attack to gain a shell on the host.

Description

The remote Apache server is running a version of mod_ssl which is older than 2.8.7. There is a bug in this module which may allow an attacker to obtain a shell on this host.

Solution

Upgrade to mod_ssl 2.8.7 or higher.

See Also

archives.neohapsis.com/archives/bugtraq/2002-02/0313.html

Plugin Details

Severity: High

ID: 800557

File Name: 800557.prm

Family: Web Servers

Nessus ID: 10888

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2002-0082

BID: 4189