Apache < 2.2.10 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 800555

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Apache HTTP Server earlier than 2.2.10 are potentially affected by multiple vulnerabilities :

- An information disclosure vulnerability in mod_proxy_http. Note that this only affects Apache on Unix systems. (CVE-2010-2791)

- The mod_proxy_ftp module in the version of Apache installed on the remote host fails to properly sanitize user-supplied URL input before using it to generate dynamic HTML output. Using specially crafted requests for FTP URLs with globbing characters (such as asterisk, tilde, opening square bracket, etc.), an attacker may be able to leverage this issue to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site. (CVE-2008-2939)

Solution

Either disable the affected module or upgrade to version 2.2.10 or higher.

See Also

http://www.securityfocus.com/archive/1/495180/100/0/threaded

http://www.apache.org/dist/httpd/CHANGES_2.2

http://httpd.apache.org/security/vulnerabilities_22.html

http://www.rapid7.com/advisories/R7-0033

Plugin Details

Severity: Medium

ID: 800555

File Name: 800555.prm

Family: Web Servers

Nessus ID: 34433

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2008-2939, CVE-2010-2791

BID: 30560, 42102