Apache 2.2 < 2.2.22 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800552


The remote web server is vulnerable to multiple attack vectors.


Versions of Apache 2.2 earlier than 2.2.22 are potentially affected by the following vulnerabilities :

- When configured as a reverse proxy, improper use of the RewriteRule and ProxyPasssMatch directives could cause the web server to proxy requests to arbitrary hosts. This could allow a remote attacker to indirectly send request to intranet servers. (CVE-2011-3368, CVE-2011-4317)

- A heap-based buffer overflow exists when mod_setenvif module is enabled and both a maliciously crafted 'SetEnvIf' directive and a maliciously crafted HTTP request header are used. (CVE-2011-3607)

- A format string handling error can allow the server to be crashed via maliciously crafted cookies. (CVE-2012-0021)

- An error exists in 'scoreboard.c' that can allow local attackers to crash the server during shutdown. (CVE-2012-0031)

- An error exists in 'protocol.c' that can allow 'HTTPOnly' cookies to be exposed to attackers through the malicious use of either long or malformed HTTP headers. (CVE-2012-0053)

- An error in the mod_proxy_ajp module when used to connect to a backend server that takes an overly long time to respond could lead to a temporary denial of service. (CVE-2012-4557)


Upgrade to Apache version 2.2.22 or later.

See Also



Plugin Details

Severity: High

ID: 800552

Family: Web Servers

Published: 2012/02/06

Nessus ID: 57791

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 5

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2012/01/31

Vulnerability Publication Date: 2011/10/05

Reference Information

CVE: CVE-2011-3368, CVE-2011-3607, CVE-2011-4317, CVE-2012-0021, CVE-2012-0031, CVE-2012-0053, CVE-2012-4557

BID: 49957, 50494, 50802, 51407, 51705, 51706, 56753