FileZilla FTP Server < 0.9.17 MLSD Command Overflow

Medium Log Correlation Engine Plugin ID 800514

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running FileZilla, an FTP server. There is a flaw in the remote version of this software that may allow an authenticated attacker to issue a malformed request such that a buffer overflow occurs. Successful exploitation would result in the attacker executing arbitrary code.

Solution

Upgrade to version 0.9.17 or higher.

See Also

sf.net/projects/filezilla

Plugin Details

Severity: Medium

ID: 800514

File Name: 800514.prm

Family: FTP Servers

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:U/RC:ND

Reference Information

CVE: CVE-2006-2173

BID: 17802