Firebird SQL Server for Linux 2.5.x < 2.5.7 / 3.0.x < 3.0.2 UDF Libraries RCE

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A database server installed on the remote host is affected by a remote
code execution vulnerability.

Description :

The version of Firebird SQL Server for Linux installed on the remote
host is 2.5.x prior to 2.5.7 or 3.0.x prior to 3.0.2. It is, therefore,
affected by a flaw in the UDF component due to insufficient restrictions
on access to external functions by the symbols of the UDF library. An
authenticated, remote attacker can exploit this issue, via a 'system'
entry point from fbudf.so, to execute arbitrary code in the context of
the Firebird server process.

See also :

http://tracker.firebirdsql.org/browse/CORE-5474
http://www.nessus.org/u?ad85ce8e
http://www.nessus.org/u?b4ea4669
http://www.nessus.org/u?58e79841

Solution :

Upgrade to Firebird SQL Server version 2.5.7 / 3.0.2 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.4
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: General

Nessus Plugin ID: 99132 ()

Bugtraq ID: 97070

CVE ID: CVE-2017-6369

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now