Intel Management Engine Insecure Read / Write Operations RCE (INTEL-SA-00075) (remote check)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The management engine on the remote host is affected by a remote code
execution vulnerability.

Description :

The Intel Management Engine on the remote host has Active Management
Technology (AMT) enabled, and according to its self-reported version
in the banner, it is running Intel manageability firmware version 6.x
prior to 6.2.61.3535, 7.x prior to 7.1.91.3272, 8.x prior to
8.1.71.3608, 9.0.x or 9.1.x prior to 9.1.41.3024, 9.5.x prior to
9.5.61.3012, 10.0.x prior to 10.0.55.3000, 11.0.18.x prior to
11.0.18.3003, 11.0.22.x prior to 11.0.22.3001, 11.0.x prior to
11.0.25.3001, 11.6.12.x prior to 11.6.12.3202, or else 11.5.x or
11.6.x prior to 11.6.27.3264. It is, therefore, affected by a remote
code execution vulnerability due to insecure read and write
operations. An unauthenticated, remote attacker can exploit this to
execute arbitrary code.

Note that the vulnerability is only exploitable remotely if either
Active Management Technology (AMT), Intel Standard Manageability
(ISM), or Small Business Technology (SBT) is enabled. However, a local
attacker can still exploit the vulnerability even if these components
are disabled by simply re-enabling the components.

See also :

http://www.nessus.org/u?9e6ca5f4
https://downloadcenter.intel.com/download/26754
https://mjg59.dreamwidth.org/48429.html
https://www.embedi.com/news/mythbusters-cve-2017-5689

Solution :

Contact your system OEM for updated firmware per the vendor advisory.

Alternatively, apply these mitigations per the INTEL-SA-00075
mitigation guide :

- Unprovision Intel manageability SKU clients.
- Disable or remove the Local Manageability Service (LMS).
- Configure local manageability configuration restrictions.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 97998 ()

Bugtraq ID: 98269

CVE ID: CVE-2017-5689

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now