Adobe Flash Player <= 24.0.0.221 Multiple Vulnerabilities (APSB17-07)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 24.0.0.221. It is, therefore, affected by
multiple vulnerabilities :

- A buffer overflow condition exists that allows an
attacker to execute arbitrary code. (CVE-2017-2997)

- Multiple memory corruption issues exist that allow an
attacker to execute arbitrary code. (CVE-2017-2998,
CVE-2017-2999)

- An unspecified flaw exists in the random number
generator used for constant binding that allows an
attacker to disclose sensitive information.
(CVE-2017-3000)

- Multiple use-after-free errors exist that allow an
attacker to execute arbitrary code. (CVE-2017-3001,
CVE-2017-3002, CVE-2017-3003)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-07.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 25.0.0.127 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now