NVIDIA Windows GPU Display Driver 375.x < 376.67 / 378.x < 378.52 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A display driver installed on the remote Windows host is affected by
multiple vulnerabilities.

Description :

The version of the NVIDIA GPU display driver installed on the remote
Windows host is 375.x prior to 376.67 or 378.x prior to 378.52.
It is, therefore, affected by multiple vulnerabilities :

- Multiple overflow conditions exist in the kernel mode
layer handler (nvlddmkm.sys) for DxgkDdiEscape due to a
failure to properly calculate the input buffer size. A
local attacker can exploit these to cause a denial of
service condition or the execution of arbitrary code.
(CVE-2017-0308, CVE-2017-0324)

- Multiple integer overflow conditions exist in the kernel
mode layer handler that allow a local attacker to cause
a denial of service condition or the execution of
arbitrary code. (CVE-2017-0309)

- A flaw exists in the kernel mode layer handler due to
improper access controls that allows a local attacker to
cause a denial of service condition. (CVE-2017-0310)

- A flaw exists in the kernel mode layer handler due to
improper access controls that allows a local attacker to
cause a denial of service condition or the execution of
arbitrary code. (CVE-2017-0311)

- An overflow condition exists in the kernel mode layer
handler for DxgDdiEscape ID 0x100008B due to improper
validation of input before setting the limits for a
loop. A local attacker can exploit this to cause a
denial of service condition or potentially gain elevated
privileges. (CVE-2017-0312)

- Multiple out-of-bounds write flaws exist within the
DxgkDdiSubmitCommandVirtual() function in the kernel
mode layer handler due to improper validation of certain
size and length values. A local attacker can exploit
these to cause a denial of service condition or the
execution of arbitrary code. (CVE-2017-0313,
CVE-2017-0314)

- A flaw exists in the kernel mode layer handler for
DxgkDdiEscape due to accessing an invalid object
pointer that allows a local attacker to execute
arbitrary code. (CVE-2017-0315)

- A flaw exists in the NVIDIA GPU and GeForce Experience
Installer due to improper file permissions on the
package extraction path. A local attacker can exploit
this to manipulate extracted files and thereby
potentially gain elevated privileges. (CVE-2017-0317)

- Multiple flaws exist in the kernel mode layer handler due
to improper handling of unspecified values that allow a
local attacker to cause a denial of service condition.
(CVE-2017-0319, CVE-2017-0320)

- Multiple NULL pointer dereference flaws exist in the
kernel mode layer handler due to improper validation of
certain input. A local attacker can exploit these to
cause a denial of service condition or potentially
execute arbitrary code. (CVE-2017-0321, CVE-2017-0323)

- An array-indexing error exists in the kernel mode layer
handler due to improper validation of certain input. A
local attacker can exploit this to cause a denial of
service condition or gain elevated privileges.
(CVE-2017-0322)

See also :

http://nvidia.custhelp.com/app/answers/detail/a_id/4398

Solution :

Upgrade the NVIDIA graphics driver to version 376.67 / 378.52 or
later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now