GLSA-201701-59 : ADOdb: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201701-59
(ADOdb: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in ADOdb. Please review
the CVE identifiers referenced below for details.

Impact :

A remote attacker, through the use of SQL injection or Cross Site
Scripting (XSS) attacks, could execute arbitrary code.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201701-59

Solution :

All ADOdb users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-php/adodb-5.20.9'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 96745 ()

Bugtraq ID:

CVE ID: CVE-2016-4855
CVE-2016-7405

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now