Citrix Provisioning Services 7.x < 7.12 Multiple Vulnerabilities (CTX219580)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application running on the remote Windows host is affected by
multiple vulnerabilities.

Description :

The version of Citrix Provisioning Services running on the remote
Windows host is either 7.x prior to 7.12 or 7.6 LTSR prior to 7.6.4
LTSR. It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists due to an
overflow condition caused by improper validation of
user-supplied input. An unauthenticated, remote attacker
can exploit this to cause a denial of service condition
or the execution of arbitrary code. (CVE-2016-9676)

- An information disclosure vulnerability exists that
allows an unauthenticated, remote attacker to disclose
kernel address information. (CVE-2016-9677)

- A remote code execution vulnerability exists due to a
use-after-free error. An unauthenticated, remote
attacker can exploit this to dereference already freed
memory, resulting in the execution of arbitrary code.
(CVE-2016-9678)

- A remote code execution vulnerability exists due to a
function pointer overwrite error. An unauthenticated,
remote attacker can exploit this to execute arbitrary
code. (CVE-2016-9679)

- An information disclosure vulnerability exists that
allows an unauthenticated, remote attacker to disclose
kernel memory. (CVE-2016-9680)

See also :

http://support.citrix.com/article/CTX219580

Solution :

Upgrade to Citrix Provisioning Services version 7.12 or later. If the
7.6 LTSR version is in use, then upgrade to version 7.6.4 LTSR.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 96630 ()

Bugtraq ID: 95620

CVE ID: CVE-2016-9676
CVE-2016-9677
CVE-2016-9678
CVE-2016-9679
CVE-2016-9680

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now