ClamAV < 0.99.2 Multiple libclamav DoS

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The antivirus service running on the remote host is affected by
multiple denial of service vulnerabilities.

Description :

According to its version, the ClamAV clamd antivirus daemon running on
the remote host is prior to 0.99.2. It is, therefore, affected by
multiple vulnerabilities :

- A denial of service vulnerability exists in the
libclamav library when handling specially crafted mew
packer executables. An unauthenticated, remote attacker
can exploit this, by convincing a user to open a
specially crafted file, to crash the application.
(CVE-2016-1371)

- Multiple denial of service vulnerabilities exist in the
libclamav library when handling specially crafted 7z
files. An unauthenticated, remote attacker can exploit
these, by convincing a user to open a specially crafted
file, to crash the application. (CVE-2016-1372)

See also :

http://blog.clamav.net/2016/05/clamav-0992-has-been-released.html
https://foxglovesecurity.com/2016/06/13/finding-pearls-fuzzing-clamav/

Solution :

Upgrade to ClamAV version 0.99.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.4
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 93897 ()

Bugtraq ID: 93221
93222

CVE ID: CVE-2016-1371
CVE-2016-1372

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now