IBM WebSphere MQ 7.1 < 7.1.0.8 / 7.5 < 7.5.0.7 / 8.0 < 8.0.0.5 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

A message queuing service installed on the remote host is affected
by multiple vulnerabilities.

Description :

According to its self-reported version, the IBM WebSphere MQ server
installed on the remote Windows host is version 7.1 without fix pack
7.1.0.8, 7.5 without fix pack 7.5.0.7, or 8.0 without fix pack
8.0.0.5. It is, therefore, affected by multiple vulnerabilities :

- A buffer overflow condition exists in IBM JVM due to
improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition or the execution of
arbitrary code under limited circumstances.
(CVE-2016-0264)

- An unspecified flaw exists in the JCE subcomponent that
allows an unauthenticated, remote attacker to disclose
potentially sensitive information. (CVE-2016-3426)

- An unspecified flaw exists in the JMX subcomponent that
allows an unauthenticated, remote attacker to impact
confidentiality, integrity, and availability. No other
details are available. (CVE-2016-3427)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21982566

Solution :

Apply the appropriate fix pack according to the vendor advisory.
Alternatively, interim fix IT14908 can also be applied to mitigate
these vulnerabilities if a fix pack is not available.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 93049 ()

Bugtraq ID: 86421
86449

CVE ID: CVE-2016-0264
CVE-2016-3426
CVE-2016-3427

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now