Citrix XenServer Multiple Vulnerabilities (CTX214954) (Bunker Buster)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The version of Citrix XenServer running on the remote host is missing
a security hotfix. It is, therefore, affected by multiple
vulnerabilities :

- A privilege escalation vulnerability known as 'Bunker
Buster' exists in the paravirtualization (PV) pagetable
implementation due to incorrect usage of fast-paths for
making updates to pre-existing pagetable entries. An
attacker with administrative privileges on a PV guest
can exploit this vulnerability to gain administrative
privileges on the host operating system. This
vulnerability only affects PV guests on x86 hardware;
HVM and ARM guests are not affected. (CVE-2016-6258)

- A denial of service vulnerability exists when handling
32-bit exceptions and event delivery due to missing SMAP
whitelisting. A local guest attacker can exploit this to
trigger a safety check that will crash other virtual
machines on the host system. This vulnerability only
exists on 32-bit PV guests running on x86 hardware that
supports SMAP. (CVE-2016-6259)

See also :

https://support.citrix.com/article/CTX214954
http://www.nessus.org/u?9e5f1cb7
http://www.nessus.org/u?83872af7

Solution :

Apply the appropriate hotfix as referenced in the vendor advisory.

Risk factor :

High / CVSS Base Score : 7.7
(CVSS2#AV:A/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 5.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 92723 ()

Bugtraq ID: 92130
92131

CVE ID: CVE-2016-6258
CVE-2016-6259

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now