Apache 2.4.18 / 2.4.20 X.509 Certificate Authentication Bypass

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by an authentication bypass

Description :

According to its banner, the version of Apache running on the remote
host is either 2.4.18 or 2.4.20. Additionally, HTTP/2 is enabled over
TLS or SSL. It is, therefore, affected by the an authentication bypass
vulnerability in the experimental module for the HTTP/2 protocol due
to a failure to correctly validate X.509 certificates, allowing access
to resources that otherwise would not be allowed. An unauthenticated,
remote attacker can exploit this to disclose potentially sensitive

See also :


Solution :

Upgrade to Apache version 2.4.23 or later. Alternatively, as a
temporary workaround, HTTP/2 can be disabled by changing the
configuration by removing 'h2' and 'h2c' from the Protocols line(s)
in the configuration file.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 92320 ()

Bugtraq ID: 91566

CVE ID: CVE-2016-4979

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now