Google Chrome < 49.0.2623.108 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is
prior to 49.0.2623.108. It is, therefore, affected by multiple
vulnerabilities :

- An out-of-bounds read error exists in Google V8 that
allows an attacker to crash the application, resulting
in a denial of service. (CVE-2016-1646)

- A use-after-free error exists in the Navigation
component that allows an attacker to dereference already
freed memory, resulting in the execution of arbitrary
code. (CVE-2016-1647)

- A use-after-free error exists in the Extensions
component that allows an attacker to dereference already
freed memory, resulting in the execution of arbitrary
code. (CVE-2016-1648)

- An overflow condition exists in libANGLE due to improper
validation of user-supplied input. An attacker can
exploit this to execute arbitrary code. (CVE-2016-1649)

- An unspecified flaw exists in the pageCapture extension
that allows an attacker to have an unspecified impact.
(CVE-2016-1650)

- A denial of service vulnerability exists in PDFium due
to improper handling of file names. An attacker can
exploit this to crash the application, resulting in a
denial of service. (VulnDB 136296)

See also :

http://www.nessus.org/u?7f954aee

Solution :

Upgrade to Google Chrome version 49.0.2623.108 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 90195 ()

Bugtraq ID:

CVE ID: CVE-2016-1646
CVE-2016-1647
CVE-2016-1648
CVE-2016-1649
CVE-2016-1650

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now