Adobe AIR for Mac <= 20.0.0.260 Multiple Vulnerabilities (APSB16-08)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe AIR installed on the remote Mac OS X host is
prior or equal to version 20.0.0.260. It is, therefore, affected by
multiple vulnerabilities :

- Multiple integer overflow conditions exist that allow an
attacker to execute arbitrary code. (CVE-2016-0963,
CVE-2016-0993, CVE-2016-1010)

- Multiple use-after-free errors exist that allow an
attacker to execute arbitrary code. (CVE-2016-0987,
CVE-2016-0988, CVE-2016-0990, CVE-2016-0991,
CVE-2016-0994, CVE-2016-0995, CVE-2016-0996,
CVE-2016-0997, CVE-2016-0998, CVE-2016-0999,
CVE-2016-1000)

- A heap overflow condition exists that allows an attacker
to execute arbitrary code. (CVE-2016-1001)

- Multiple memory corruption issues exist that allow an
attacker to execute arbitrary code. (CVE-2016-0960,
CVE-2016-0961, CVE-2016-0962, CVE-2016-0986,
CVE-2016-0989, CVE-2016-0992, CVE-2016-1002,
CVE-2016-1005)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-08.html

Solution :

Upgrade to Adobe AIR version 21.0.0.176 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true