MS16-026: Security Update for Graphic Fonts to Address Remote Code Execution (3143148)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host is affected by multiple vulnerabilities.

Description :

The remote Windows host is affected by multiple vulnerabilities in
the Adobe Type Manager Library :

- A denial of service vulnerability exists due to improper
handling of OpenType fonts. A remote attacker can
exploit this vulnerability by convincing a user to open
a file or visit a website containing specially crafted
embedded OpenType fonts, resulting in a denial of
service condition. (CVE-2016-0120)

- A remote code execution vulnerability exists due to
improper handling of specially crafted fonts. A remote
attacker can exploit this vulnerability by convincing a
user to open a file or visit a website containing
specially crafted embedded OpenType fonts, resulting in
the execution of arbitrary code in the context of the
current user. (CVE-2016-0121)

See also :

https://technet.microsoft.com/library/security/ms16-026

Solution :

Microsoft has released a set of patches for Windows Vista, 2008, 7,
2008 R2, 2012, 8.1, RT 8.1, 2012 R2, and 10.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 89749 ()

Bugtraq ID: 84027
84071

CVE ID: CVE-2016-0120
CVE-2016-0121

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now