OpenSSL 1.0.1 < 1.0.1s Multiple Vulnerabilities (DROWN)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.1 prior to 1.0.1s. It is, therefore, affected by the
following vulnerabilities :

- A key disclosure vulnerability exists due to improper
handling of cache-bank conflicts on the Intel
Sandy-bridge microarchitecture. An attacker can exploit
this to gain access to RSA key information.
(CVE-2016-0702)

- A double-free error exists due to improper validation of
user-supplied input when parsing malformed DSA private
keys. A remote attacker can exploit this to corrupt
memory, resulting in a denial of service condition or
the execution of arbitrary code. (CVE-2016-0705)

- A NULL pointer dereference flaw exists in the
BN_hex2bn() and BN_dec2bn() functions. A remote attacker
can exploit this to trigger a heap corruption, resulting
in the execution of arbitrary code. (CVE-2016-0797)

- A denial of service vulnerability exists due to improper
handling of invalid usernames. A remote attacker can
exploit this, via a specially crafted username, to leak
300 bytes of memory per connection, exhausting available
memory resources. (CVE-2016-0798)

- Multiple memory corruption issues exist that allow a
remote attacker to cause a denial of service condition
or the execution of arbitrary code. (CVE-2016-0799)

- A flaw exists that allows a cross-protocol
Bleichenbacher padding oracle attack known as DROWN
(Decrypting RSA with Obsolete and Weakened eNcryption).
This vulnerability exists due to a flaw in the Secure
Sockets Layer Version 2 (SSLv2) implementation, and it
allows captured TLS traffic to be decrypted. A
man-in-the-middle attacker can exploit this to decrypt
the TLS connection by utilizing previously captured
traffic and weak cryptography along with a series of
specially crafted connections to an SSLv2 server that
uses the same private key. (CVE-2016-0800)

See also :

https://www.openssl.org/news/secadv/20160301.txt
https://www.openssl.org/news/cl101.txt
https://drownattack.com/

Solution :

Upgrade to OpenSSL version 1.0.1s or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 89081 ()

Bugtraq ID: 83705
83733
83754
83755
83763

CVE ID: CVE-2016-0702
CVE-2016-0705
CVE-2016-0797
CVE-2016-0798
CVE-2016-0799
CVE-2016-0800

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now