Apache Tomcat 7.0.x < 7.0.68 Multiple Vulnerabilities

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the Apache Tomcat
service running on the remote host is 7.0.x prior to 7.0.68. It is,
therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to
a failure to enforce access restrictions when handling
directory requests that are missing trailing slashes. An
unauthenticated, remote attacker can exploit this to
enumerate valid directories. (CVE-2015-5345)

- An information disclosure vulnerability exists in the
Manager and Host Manager web applications due to a flaw
in the index page when issuing redirects in response to
unauthenticated requests for the root directory of the
application. An unauthenticated, remote attacker can
exploit this to gain access to the XSRF token
information stored in the index page. Note that the
Apache Tomcat advisory does not list Tomcat version
7.0.0 as affected by this vulnerability. (CVE-2015-5351)

- An information disclosure vulnerability exists that
allows a specially crafted web application to load the
StatusManagerServlet. An attacker can exploit this to
gain unauthorized access to a list of all deployed
applications and a list of the HTTP request lines for
all requests currently being processed. (CVE-2016-0706)

- A security bypass vulnerability exists due to a flaw
in the StandardManager, PersistentManager, and cluster
implementations that is triggered when handling
persistent sessions. An unauthenticated, remote attacker
can exploit this, via a crafted object in a session, to
bypass the security manager and execute arbitrary code.
(CVE-2016-0714)

- A flaw exists due to the setGlobalContext() method of
ResourceLinkFactory being accessible to web applications
even when run under a security manager. An
unauthenticated, remote attacker can exploit this to
inject malicious global context, allowing data owned by
other web applications to be read or written to.
(CVE-2016-0763)

Note that Nessus has not attempted to exploit these issues but has
instead relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?40843ffb

Solution :

Upgrade to Apache Tomcat version 7.0.68 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 88936 ()

Bugtraq ID: 83324
83326
83327
83328
83330

CVE ID: CVE-2015-5345
CVE-2015-5351
CVE-2016-0706
CVE-2016-0714
CVE-2016-0763

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now