MS16-002: Cumulative Security Update for Microsoft Edge (3124904)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote host has a web browser installed that is affected by
multiple vulnerabilities.

Description :

The version of Microsoft Edge installed on the remote host is missing
Cumulative Security Update 3124904. It is, therefore, affected by
multiple remote code execution vulnerabilities :

- A remote code execution vulnerability exists due to
improper handling of objects in memory. An attacker can
exploit this vulnerability by convincing a user to visit
a specially crafted website, resulting in execution of
arbitrary code in the context of the current user.
(CVE-2016-0003)

- A remote code execution vulnerability exists in the
Chakra JavaScript engine due to improper handling of
objects in memory. An attacker can exploit this
vulnerability by convincing a user to visit a specially
crafted website, resulting in execution of arbitrary
code in the context of the current user. (CVE-2016-0024)

See also :

https://technet.microsoft.com/library/security/MS16-002

Solution :

Microsoft has released a set of patches for Windows 10.

Note that Windows 10 with Citrix XenDesktop installed will not be
offered the patch due to an issue with the XenDesktop software that
prevents users from logging on when the patch is applied. To apply the
patch you must first uninstall XenDesktop or contact Citrix for help
with the issue.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 87878 ()

Bugtraq ID: 79893

CVE ID: CVE-2016-0003
CVE-2016-0024

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now