Adobe AIR for Mac <= 20.0.0.204 Multiple Vulnerabilities (APSB16-01)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe AIR installed on the remote Mac OS X host is
equal or prior to version 20.0.0.204. It is, therefore, affected by
multiple vulnerabilities :

- A type confusion error exists that a remote attacker can
exploit to execute arbitrary code. (CVE-2015-8644)

- An integer overflow condition exists that a remote
attacker can exploit to execute arbitrary code.
(CVE-2015-8651)

- Multiple use-after-free errors exist that a remote
attacker can exploit to execute arbitrary code.
(CVE-2015-8634, CVE-2015-8635, CVE-2015-8638,
CVE-2015-8639, CVE-2015-8640, CVE-2015-8641,
CVE-2015-8642, CVE-2015-8643, CVE-2015-8646,
CVE-2015-8647, CVE-2015-8648, CVE-2015-8649,
CVE-2015-8650, CVE-2016-0959)

- Multiple memory corruption issues exist that allow a
remote attacker to execute arbitrary code.
(CVE-2015-8459, CVE-2015-8460, CVE-2015-8636,
CVE-2015-8645)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-01.html

Solution :

Upgrade to Adobe AIR version 20.0.0.233 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now