Apache Traffic Server 5.3.x < 5.3.1 'url_sig' Plugin Multiple Vulnerabilities

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote caching server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache Traffic Server running
on the remote host is 5.3.x prior to 5.3.1. It is, therefore, affected
by multiple vulnerabilities related to the 'url_sig' plugin :

- An out-of-bounds access error exists that is triggered
when handling a specially crafted HTTP request. An
unauthenticated, remote attacker can exploit this to
crash the server. (VulnDB 128881)

- A security bypass vulnerability exists due to a flaw
that is triggered when handling empty secret key URLs.
An unauthenticated, remote attacker can exploit this to
bypass validation mechanisms, thereby gaining access to
protected assets. (VulnDB 128882)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?b450befb
http://www.nessus.org/u?c77e9f28

Solution :

Upgrade to Apache Traffic Server version 5.3.1 or later.
Alternatively, disable the 'url_sig' plugin.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 5.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 87240 ()

Bugtraq ID:

CVE ID: CVE-2015-3249

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now