OpenSSL 1.0.2 < 1.0.2e Multiple Vulnerabilities

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.

Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.2 prior to 1.0.2e. It is, therefore, affected by the
following vulnerabilities :

- A flaw exists in the ssl3_get_key_exchange() function
in file s3_clnt.c when handling a ServerKeyExchange
message for an anonymous DH ciphersuite with the value
of 'p' set to 0. A attacker can exploit this, by causing
a segmentation fault, to crash an application linked
against the library, resulting in a denial of service.

- A carry propagating flaw exists in the x86_64 Montgomery
squaring implementation that may cause the BN_mod_exp()
function to produce incorrect results. An attacker can
exploit this to obtain sensitive information regarding
private keys. (CVE-2015-3193)

- A NULL pointer dereference flaw exists in file
rsa_ameth.c when handling ASN.1 signatures that use the
RSA PSS algorithm but are missing a mask generation
function parameter. A remote attacker can exploit this
to cause the signature verification routine to crash,
leading to a denial of service. (CVE-2015-3194)

- A flaw exists in the ASN1_TFLG_COMBINE implementation in
file tasn_dec.c related to handling malformed
X509_ATTRIBUTE structures. A remote attacker can exploit
this to cause a memory leak by triggering a decoding
failure in a PKCS#7 or CMS application, resulting in a
denial of service. (CVE-2015-3195)

See also :

Solution :

Upgrade to OpenSSL version 1.0.2e or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 87222 ()

Bugtraq ID: 78623

CVE ID: CVE-2015-1794

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now