Adobe Flash Player for Mac <= 19.0.0.207 Vulnerability (APSB15-27)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Mac OS X
host is equal or prior to version 19.0.0.207. It is, therefore,
affected by multiple vulnerabilities :

- Multiple type confusion errors exist that allow a remote
attacker to execute arbitrary code. (CVE-2015-7645,
CVE-2015-7647, CVE-2015-7648)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-27.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 19.0.0.226 or later.

Alternatively, Adobe has made version 18.0.0.255 available for those
installations that cannot be upgraded to the latest version.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 86424 ()

Bugtraq ID:

CVE ID: CVE-2015-7645
CVE-2015-7647
CVE-2015-7648

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now