Advantech WebAccess < 7.0-2011.12.20 Multiple Vulnerabilities

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The version of Advantech WebAccess running on the remote host is prior
to version 7.0-2011.12.20. It is, therefore, affected multiple
vulnerabilities :

- A cross-site scripting vulnerability exist due to
improper validation of unspecified input. A remote
attacker, using a specially crafted request, can exploit
this to execute arbitrary script code in the browser
in the context of the user's session. (VulnDB 124949)

- A SQL injection vulnerability exists due to unspecified
input not being properly sanitized before processing SQL
queries. A remote attacker can exploit this to inject
SQL queries against the database, resulting in the
disclosure or manipulation of arbitrary data.
(VulnDB 124950)

See also :

http://www.nessus.org/u?32c8d148

Solution :

Upgrade to Advantech WebAccess version 7.0-2011.12.20 or higher.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SCADA

Nessus Plugin ID: 85692 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now