OpenSSH 7.x < 7.1 PermitRootLogin Security Bypass

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The SSH server running on the remote host is affected by a security
bypass vulnerability.

Description :

According to its banner, the version of OpenSSH running on the remote
host is 7.x prior to 7.1. It is, therefore, affected by a security
bypass vulnerability due to a logic error that is triggered under
certain compile-time configurations when PermitRootLogin is set to
'prohibit-password' or 'without-password'. An unauthenticated, remote
attacker can exploit this to permit password authentication to root
while preventing other forms of authentication.

See also :

http://www.openssh.com/txt/release-7.1

Solution :

Upgrade to OpenSSH 7.1 or later.

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 1.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 85690 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now