Adobe Flash Player <= 18.0.0.203 Multiple RCE Vulnerabilities (APSB15-18)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple remote code execution vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 18.0.0.203. It is, therefore, affected by
multiple remote code execution vulnerabilities :

- A use-after-free error exists in the opaqueBackground
class in the ActionScript 3 (AS3) implementation. A
remote attacker, via specially crafted Flash content,
can dereference already freed memory, resulting in the
execution of arbitrary code. (CVE-2015-5122)

- A use-after-free error exists in the BitmapData class in
the ActionScript 3 (AS3) implementation. A remote
attacker, via specially crafted Flash content, can
dereference already freed memory, resulting in the
execution of arbitrary code. (CVE-2015-5123)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-18.html

Solution :

Upgrade to Adobe Flash Player version 18.0.0.209 or later.

Alternatively, Adobe has made version 13.0.0.309 available for those
installations that cannot be upgraded to 18.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 84730 ()

Bugtraq ID: 75710
75712

CVE ID: CVE-2015-5122
CVE-2015-5123

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now