Adobe AIR <= 17.0.0.124 Multiple Vulnerabilities (APSB15-05)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a version of Adobe AIR installed that is
affected by multiple vulnerabilities.

Description :

According to its version, the installation of Adobe AIR on the remote
Windows host is equal or prior to 17.0.0.124. It is, therefore,
affected by multiple vulnerabilities :

- Multiple memory corruption flaws exist due to improper
validation of user-supplied input. An attacker can
exploit these flaws to execute arbitrary code.
(CVE-2015-0332, CVE-2015-0333, CVE-2015-0335,
CVE-2015-0339)

- Multiple type confusions flaws exist that allow an
attacker to execute arbitrary code. (CVE-2015-0334,
CVE-2015-0336)

- A unspecified flaw exists that allows an attacker to
bypass cross-domain policy. (CVE-2015-0337)

- An integer overflow condition exists due improper
validation of user-supplied input. An attacker can
exploit to execute arbitrary code. (CVE-2015-0338)

- A unspecified flaw exists that allows an attacker to
bypass restrictions and upload arbitrary files.
(CVE-2015-0340)

- Multiple use-after-free errors exist that allow an
attacker to deference already freed memory and execute
arbitrary code. (CVE-2015-0341, CVE-2015-0342)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-05.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe AIR 17.0.0.144 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now