VMware Horizon View Client 3.2.x < 3.2.1 / 3.3.x < 3.4.0 / or 5.x < 5.4.2 Multiple Vulnerabilities (VMSA-2015-0004)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtual desktop solution installed that is
affected by multiple vulnerabilities.

Description :

The version of VMware Horizon View Client installed on the remote host
is 3.2.x prior to 3.2.1, 3.3.x prior to 3.4.0, or 5.x (with local
mode) prior to 5.4.2. It is, therefore, affected by multiple
vulnerabilities :

- An arbitrary code execution vulnerability exists due to
a stack-based buffer overflow condition in the JPEG2000
plugin that is triggered when parsing a Quantization
Default (QCD) marker segment in a JPEG2000 (JP2) image
file. A remote attacker can exploit this, using a
specially crafted image, to execute arbitrary code or
cause a denial of service condition. (CVE-2012-0897)

- Multiple denial of service vulnerabilities exist due to
improper memory allocation by the TPView.dll and
TPInt.dll libraries. A remote attacker can exploit this
to cause a denial of service condition. (CVE-2015-2338,
CVE-2015-2339, CVE-2015-2340)

- Multiple remote code execution vulnerabilities exist due
to improper memory allocation by the TPView.dll and
TPInt.dll libraries. A remote attacker can exploit this
to execute arbitrary code. (CVE-2015-2336,
CVE-2015-2337)

See also :

https://www.vmware.com/security/advisories/VMSA-2015-0004

Solution :

Upgrade to VMware Horizon View Client 3.2.1 / 3.4.0 / 5.4.2 (with
local mode) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 84150 ()

Bugtraq ID: 51426
75092
75095

CVE ID: CVE-2012-0897
CVE-2015-2336
CVE-2015-2337
CVE-2015-2338
CVE-2015-2339
CVE-2015-2340

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now