Adobe Reader < 10.1.14 / 11.0.11 Multiple Vulnerabilities (APSB15-10)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.

Synopsis :

The version of Adobe Reader on the remote Windows host is affected by
multiple vulnerabilities.

Description :

The version of Adobe Reader installed on the remote host is a version
prior to 10.1.14 / 11.0.11. It is, therefore, affected by the
following vulnerabilities :

- A buffer overflow condition exists in CoolType.dll due
to improper validation of user-supplied input. A remote
attacker can exploit this to execute arbitrary code.

- An out-of-bounds read flaw exists in CoolType.dll due
to improper validation of user-supplied input. A remote
attacker, via a specially crafted PDF file, can cause
the application to crash and disclose memory contents.

- Multiple input validation, NULL pointer dereference, and
use-after-free flaws exist that allow memory corruption,
arbitrary code execution, and buffer overflow attacks.
(CVE-2015-3047,CVE-2015-3048, CVE-2015-3049,
CVE-2015-3050, CVE-2015-3051, CVE-2015-3052,
CVE-2015-3053, CVE-2015-3054, CVE-2015-3055,
CVE-2015-3056, CVE-2015-3057, CVE-2015-3058,
CVE-2015-3059, CVE-2015-3070, CVE-2015-3075,

- Multiple unspecified flaws in the JavaScript API allow
an attacker to bypass JavaScript API restrictions.
(CVE-2015-3060, CVE-2015-3061, CVE-2015-3062,
CVE-2015-3063, CVE-2015-3064, CVE-2015-3065,
CVE-2015-3066, CVE-2015-3067, CVE-2015-3068,
CVE-2015-3069, CVE-2015-3071, CVE-2015-3072,
CVE-2015-3073, CVE-2015-3074)

- An XML external entity injection flaw exists that allows
information disclosure. (CVE-2014-8452)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

Solution :

Upgrade to Adobe Reader 10.1.14 / 11.0.11 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.7
Public Exploit Available : true