SeaMonkey < 2.33.1 Multiple Vulnerabilities

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Mozilla SeaMonkey installed on the remote host is prior
to 2.33.1. It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists due to an
out-of-bounds error in typed array bounds checking
within 'asmjs/AsmJSValidate.cpp', which relates to
just-in-time compilation for JavaScript. A remote
attacker, using a specially crafted web page, can
exploit this to execute arbitrary code by reading and
writing to memory. (CVE-2015-0817)

- A privilege escalation vulnerability exists due to a
flaw within 'docshell/base/nsDocShell.cpp', which
relates to SVG format content navigation. A remote
attacker can exploit this to bypass same-origin policy
protections, allowing a possible execution of arbitrary
scripts in a privileged context. (CVE-2015-0818)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2015-28/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-29/

Solution :

Upgrade to SeaMonkey 2.33.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 82042 ()

Bugtraq ID: 73263
73265

CVE ID: CVE-2015-0817
CVE-2015-0818

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now