MS KB3044132: Update for Vulnerabilities in Adobe Flash Player in Internet Explorer

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

The remote Windows host is missing KB3044132. It is, therefore,
affected by the following vulnerabilities :

- Multiple memory corruption issues exist due to not
properly validating user input, which an attacker can
exploit to execute arbitrary code. (CVE-2015-0332,
CVE-2015-0333, CVE-2015-0335, CVE-2015-0339)

- Multiple type confusions flaws exist, which an attacker
can exploit to execute arbitrary code. (CVE-2015-0334,
CVE-2015-0336)

- An unspecified flaw exists that allows an attacker to
bypass cross-domain policy. (CVE-2015-0337)

- An integer overflow condition exists due to not properly
validating user input, which an attacker can exploit to
execute arbitrary code. (CVE-2015-0338)

- An unspecified flaw exists that allows an attacker to
bypass restrictions and upload arbitrary files.
(CVE-2015-0340)

- Multiple use-after-free errors exist that can allow an
attacker to deference already freed memory and execute
arbitrary code. (CVE-2015-0341, CVE-2015-0342)

See also :

https://technet.microsoft.com/library/security/2755801
https://support.microsoft.com/kb/3044132
https://helpx.adobe.com/security/products/flash-player/apsb15-05.html

Solution :

Install Microsoft KB3044132.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now