Apache Struts 2.0.0 < 2.3.16.1 Multiple Vulnerabilities (credentialed check)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a web application that uses a Java
framework that is affected by multiple vulnerabilities.

Description :

The remote web application appears to use Struts 2, a web framework
that utilizes OGNL (Object-Graph Navigation Language) as an expression
language. The version of Struts 2 in use is affected by multiple
vulnerabilities :

- A denial of service vulnerability exists due to an issue
in the Commons FileUpload version 1.3 that allows remote
attackers to cause an infinite loop via a crafted
Content-Type header. (CVE-2014-0050)

- A security bypass vulnerability exists due to the
application allowing manipulation of the ClassLoader
via the 'class' parameter, which is directly mapped to
the getClass() method. A remote, unauthenticated
attacker can manipulate the ClassLoader used by the
application server, resulting in a bypass of certain
security restrictions. (CVE-2014-0094)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://struts.apache.org/docs/version-notes-23161.html
http://struts.apache.org/docs/s2-020.html

Solution :

Upgrade to version 2.3.16.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 81105 ()

Bugtraq ID: 65400
65999

CVE ID: CVE-2014-0050
CVE-2014-0094

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now