IBM WebSphere Service Registry and Repository 7.0 < 7.0.0.5 Multiple Vulnerabilities

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a web application installed that is affected by
multiple vulnerabilities.

Description :

The version of IBM WebSphere Service Registry and Repository (WSRR) is
version 7.0 prior to 7.0.0.5. It is therefore, affected by multiple
vulnerabilities :

- An unspecified DOM based cross-site scripting (XSS)
vulnerability in the WSRR web UI. (CVE-2014-6132)

- WSSR web interface issues a cookie that is not declared
SSL only. (CVE-2014-6153)

- An unspecified information disclosure flaw related to
access control checks when a retrieve depth is 0.
(CVE-2014-6177)

- An unspecified HTML injection vulnerability related to
the User-Agent header in the WSRR web UI.
(CVE-2014-6180)

- An unspecified information disclosure flaw related to
the lack of access controls to contained objects.
(CVE-2014-6181)

- Improper enforcement of object access control
restrictions. (CVE-2014-6186)

- An unspecified cross-site request forgery (XSRF)
vulnerability. (CVE-2014-6187)

- Unspecified cross-site scripting (XSS) vulnerabilities.
(CVE-2014-6188)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21693381

Solution :

Upgrade to IBM WebSphere Service Registry and Repository Fix Pack
7.0.0.5 and contact the vendor for solutions to CVE-2014-6132,
CVE-2014-6153, CVE-2014-6186, and CVE-2014-6188.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N)
CVSS Temporal Score : 3.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now