GLSA-201412-33 : PowerDNS Recursor: Multiple vulnerabilities

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201412-33
(PowerDNS Recursor: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PowerDNS Recursor.
Please review the CVE identifiers and PowerDNS blog post referenced below
for details.

Impact :

A remote attacker may be able to send specially crafted packets,
possibly resulting in arbitrary code execution or a Denial of Service
condition. Furthermore, a remote attacker may be able to spoof DNS data.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?e0bd75f6
https://security.gentoo.org/glsa/201412-33

Solution :

All PowerDNS Recursor users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-dns/pdns-recursor-3.6.1-r1'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 80210 ()

Bugtraq ID: 37650
37653
59348
71545

CVE ID: CVE-2009-4009
CVE-2009-4010
CVE-2012-1193
CVE-2014-8601

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now