Adobe Shockwave Player <= 11.6.3.633 Multiple Code Execution Vulnerabilities (APSB12-02) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is 11.6.3.633 or earlier. It is, therefore, affected by multiple
code execution vulnerabilities.

- Multiple memory corruption issues exist related to the
Shockwave 3D Asset that allow code execution.
(CVE-2012-0757, CVE-2012-0760, CVE-2012-0761,
CVE-2012-0762, CVE-2012-0763, CVE-2012-0764,
CVE-2012-0766)

- An unspecified heap-based buffer overflow exists that
allows code execution. (CVE-2012-0758)

- An unspecified memory corruption vulnerability exists
that allows to code execution. (CVE-2012-0759)

A remote attacker can exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://www.adobe.com/support/security/bulletins/apsb12-02.html

Solution :

Upgrade to Adobe Shockwave 11.6.4.634 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now