OracleVM 3.3 : libXfont (OVMSA-2014-0080)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote OracleVM host is missing a security update.

Description :

The remote OracleVM system is missing necessary patches to address
critical security updates :

- CVE-2014-0209: integer overflow of allocations in font
metadata file parsing (bug 1163602, bug 1163601)

- CVE-2014-0210: unvalidated length fields when parsing
xfs protocol replies (bug 1163602, bug 1163601)

- CVE-2014-0211: integer overflows calculating memory
needs for xfs replies (bug 1163602, bug 1163601)

- CVE-2013-6462.patch: sscanf overflow (bug 1049684)

- sscanf-hardening.patch: Some other sscanf hardening
fixes (1049684)

See also :

http://www.nessus.org/u?cfbd88e1

Solution :

Update the affected libXfont package.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: OracleVM Local Security Checks

Nessus Plugin ID: 79557 ()

Bugtraq ID: 64694
67382

CVE ID: CVE-2013-6462
CVE-2014-0209
CVE-2014-0210
CVE-2014-0211

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now