GLSA-201411-09 : Ansible: Privilege escalation

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201411-09
(Ansible: Privilege escalation)

Multiple vulnerabilities have been discovered in Ansible. Please review
the CVE identifiers referenced below for details.

Impact :

A local attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of Service condition, or obtain
sensitive information.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201411-09

Solution :

All Ansible users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-admin/ansible-1.6.8'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 79417 ()

Bugtraq ID: 68232
68335
68794
68802

CVE ID: CVE-2014-4657
CVE-2014-4678
CVE-2014-4966
CVE-2014-4967

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now