Wireshark 1.12.x < 1.12.2 Multiple DoS Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple denial of service vulnerabilities.

Description :

The remote Windows host has a version of Wireshark installed that is
1.12.x prior to 1.12.2. It is, therefore, affected by multiple denial
of service vulnerabilities in following dissectors :

- AMQP (CVE-2014-8711)
- NCP (CVE-2014-8712, CVE-2014-8713)
- SigComp (CVE-2014-8710)
- TN5250 (CVE-2014-8714)

A remote attacker, using a specially crafted packet, can cause the
application to crash.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

https://www.wireshark.org/security/wnpa-sec-2014-20.html
https://www.wireshark.org/security/wnpa-sec-2014-21.html
https://www.wireshark.org/security/wnpa-sec-2014-22.html
https://www.wireshark.org/security/wnpa-sec-2014-23.html
https://www.wireshark.org/docs/relnotes/wireshark-1.12.2.html

Solution :

Upgrade to Wireshark version 1.12.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 79252 ()

Bugtraq ID: 71069
71070
71071
71072
71073

CVE ID: CVE-2014-8710
CVE-2014-8711
CVE-2014-8712
CVE-2014-8713
CVE-2014-8714

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now