Mandriva Linux Security Advisory : php (MDVSA-2014:202)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been discovered and corrected in php :

A heap corruption issue was reported in PHP's exif_thumbnail()
function. A specially crafted JPEG image could cause the PHP
interpreter to crash or, potentially, execute arbitrary code
(CVE-2014-3670).

The updated php packages have been upgraded to the 5.5.18 version
resolve this security flaw.

Additionally, php-apc has been rebuilt against the updated php
packages.

See also :

http://php.net/ChangeLog-5.php#5.5.18

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 78664 ()

Bugtraq ID: 70665

CVE ID: CVE-2014-3670

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now