Mandriva Linux Security Advisory : nspr (MDVSA-2014:125)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been discovered and corrected in nspr :

Mozilla Netscape Portable Runtime (NSPR) before 4.10.6 allows remote
attackers to execute arbitrary code or cause a denial of service
(out-of-bounds write) via vectors involving the sprintf and console
functions (CVE-2014-1545).

The updated nspr packages have been upgraded to the 4.10.6 version
which is unaffected by this issue.

Additionally :

- The rootcerts package have been upgraded to the latest
version as of 2014-04-01.

- The nss packages have been upgraded to the latest 3.16.1
version which resolves various bugs.

- The sqlite3 packages have been upgraded to the 3.7.17
version for mbs1 due to an prerequisite to nss-3.16.1.

See also :

http://www.mozilla.org/security/announce/2014/mfsa2014-55.html
http://www.nessus.org/u?b157b539

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Mandriva Local Security Checks

Nessus Plugin ID: 76068 ()

Bugtraq ID: 67975

CVE ID: CVE-2014-1545

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now