lighttpd < 1.4.34 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of lighttpd running on the remote
host is prior to 1.4.34. It is, therefore, affected by the following
vulnerabilities :

- When Server Name Indication (SNI) is enabled, a flaw
exists that could cause the application to use all
available SSL ciphers, including weak ciphers. Remote
attackers could potentially hijack sessions or obtain
sensitive information by sniffing the network.
Note only versions 1.4.24 to 1.4.33 are affected.

- A flaw exists in the clang static analyzer because it
fails to perform checks around setuid (1), setgid (2),
and setgroups (3) calls. This could allow a remote
attacker to gain elevated privileges. (CVE-2013-4559)

- A use-after-free error exists in the clang static
analyzer, when the FAM stat cache engine is enabled.
This could allow remote attackers to dereference
already freed memory and crash the program.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

Solution :

Upgrade to lighttpd version 1.4.34 or later. Alternatively, apply the
vendor-supplied patch.

Risk factor :

High / CVSS Base Score : 7.6
CVSS Temporal Score : 5.6
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 72815 ()

Bugtraq ID: 63534

CVE ID: CVE-2013-4508

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now